Paket yüklemesi yapmak istediğinizde, örneğin OpenVPN kurmak için gerekli olan paketleri command-line’da yazdığınızda aldığınız bir hata mesajı şu şekilde olabilir:

Package network-manager-openvpn is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package ‘network-manager-openvpn’ has no installation candidate

Package is not available Hata Çözümü

Bu durum, VPN ile ilgili değildir, sadece unix source-list’inizde bilgisayarınızın paketleri alması için gereken doğru adresler – kaynaklar yoktur. Çözüm için, /etc/apt/source.list dökümanını açıp, sonuna aşağıdaki kaynak listesini ekliyoruz ve kaydediyoruz:

deb http://archive.ubuntu.com/ubuntu quantal universe
deb http://ftp.de.debian.org/debian wheezy main
deb http://http.kali.org/ /kali main contrib non-free
deb http://http.kali.org/ /wheezy main contrib non-free
deb http://http.kali.org/kali kali-dev main contrib non-free
deb http://http.kali.org/kali kali-dev main/debian-installer
deb-src http://http.kali.org/kali kali-dev main contrib non-free
deb http://http.kali.org/kali kali main contrib non-free
deb http://http.kali.org/kali kali main/debian-installer
deb-src http://http.kali.org/kali kali main contrib non-free
deb http://security.kali.org/kali-security kali/updates main contrib non-free
deb-src http://security.kali.org/kali-security kali/updates main contrib non-free
deb http://mirror.nus.edu.sg/kali/kali kali main
deb http://repo.kali.org/kali kali-bleeding-edge main

sonrasında ise:

sudo apt-get update

artık dilediğiniz paketin install  komutunu başarı ile verebilirsiniz.


Barış Parlan

I'm an earthling called Barış Parlan. a graphic designer & information technology specialist living in Cyprus. nerd, digital storyteller. doing phd about serious games and cross-reality. fan of photography, science, futurism, cyberpunk. interested in critical theory. practicing anarchism and atheism. polyamorous sapiosexual.

2 yorum

Kali · 2014-10-03 08:24 tarihinde

THIS IS BAD ADVICE WHICH WILL BREAK YOUR KALI LINUX, DO NOT FOLLOW!

    Barış Parlan · 2014-11-03 09:39 tarihinde

    Please give me explanation, how it will “break” it? I may not be an expert, I really wish to hear more information from you, since this was the only way I could solve my problem. What I did there was updating my “source.list” . What kind of harm possible?

Yorum Yaz

“Package is not available” Hatası

Okuma süresi: 1 min
2